Home / Forum
Please or Register to create posts and topics.

Can't open GUI on Macbook

Hi there,

I'm having some difficulties installing FishResp on my Macbook (10.14.5) and I was wondering if you had any advice. I have both Java (1.80_212-b10) and R (version 3.6.0) installed on my computer. I clicked on FishResp.dmg to install and downloaded the R packages successfully, but when I click on the icon to open the GUI, nothing happens. The icon shows up in my dock but the program doesn't open. I've tried to install it a few times with the same results, so I'm not sure what I'm doing wrong. In the meantime I'm learning to use the R version, but I was hoping to try out the GUI.

Thanks for your help and for making this wonderful free tool!

Hi Melissa,

Thanks for contacting us!

Do you have other versions of Java? As namely, do you have other folders than "1.80_212-b10.jdk" in the folder "library/Java/JavaVirtualMachines"?
If yes, delete the other versions and try to reinstall the program.

The other thing, that you probably should do first, is to open FishResp via Terminal and see what kind of error will be printed. To do it, just open Terminal and paste this command: "open -a FishResp"

Best wishes,


P.S. Sorry for the late response, I just found your email in a junk folder.

mp has reacted to this post.

Thanks so much for your response. I did have two versions of Java installed so I removed the unwanted version. I realized I'm also having trouble installing the mclust R library, which might be contributing to the issue. When I used the command in terminal:

cd Downloads/FishResp_mac

sudo Rscript installLibs.r


I received the following message about mclust:


* installing *source* package ‘mclust’ ...

** package ‘mclust’ successfully unpacked and MD5 sums checked

** using staged installation

** libs

gfortran  -fPIC  -Wall -g -O2  -c dmvnorm.f -o dmvnorm.o

make: gfortran: No such file or directory

make: *** [dmvnorm.o] Error 1

ERROR: compilation failed for package ‘mclust’

* removing ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/mclust’

* restoring previous ‘/Library/Frameworks/R.framework/Versions/3.6/Resources/library/mclust’

The downloaded source packages are in


Warning message:

In install.packages("mclust", repos = "") :

  installation of package ‘mclust’ had non-zero exit status

trying URL ''

Content type 'application/x-gzip' length 272826 bytes (266 KB)


downloaded 266 KB


When I try to open the GUI manually or in terminal (open -a FishResp), I get a message asking if I want to open it (I click open) but nothing happens and the program doesn't appear in my dock.

Sergey Morozov has reacted to this post.
Sergey Morozov

Something is still wrong between Java and FishResp (e.g. JAVA_HOME is pointing to other than JDK 8). So, we need to remove all Java components from your MacOS. To do it run the following commands in Terminal:

sudo rm -rf /Library/Java/*  
sudo rm -rf /Library/PreferencePanes/Java*  
sudo rm -rf /Library/Internet\ Plug-Ins/Java*

Then, install JDK 8 and run FishResp again. That should work.

But, if it is still not working, then go to the content of FishResp application and run the 'launcher' file there (the address is: "/Applications/"). Please, send me the printed info in the appeared Terminal window.

Hi Sergey,

I followed your instructions (uninstalling/reinstalling Java) and still can't seem to launch the GUI. I got the following error message from the launcher:

Cannot find JRI native library!

Please make sure that the JRI native library is in a directory listed in java.library.path.

java.lang.UnsatisfiedLinkError: /Library/Frameworks/R.framework/Versions/3.4/Resources/library/rJava/jri/libjri.jnilib: dlopen(/Library/Frameworks/R.framework/Versions/3.4/Resources/library/rJava/jri/libjri.jnilib, 1): Library not loaded: /Library/Frameworks/R.framework/Versions/3.4/Resources/lib/libR.dylib

  Referenced from: /Library/Frameworks/R.framework/Versions/3.4/Resources/library/rJava/jri/libjri.jnilib

  Reason: image not found

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(

at java.lang.ClassLoader.loadLibrary(

at java.lang.Runtime.loadLibrary0(

at java.lang.System.loadLibrary(

at org.rosuda.JRI.Rengine.<clinit>(

at com.fishrespbase.Main.initR(

at com.fishrespbase.Main.start(

at com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$166(

at com.sun.javafx.application.PlatformImpl.lambda$runAndWait$179(

at com.sun.javafx.application.PlatformImpl.lambda$null$177(

at Method)

at com.sun.javafx.application.PlatformImpl.lambda$runLater$178(


Hi Melissa,

Something is definitely wrong with rJava, but I cannot figure out what exactly, as I have not met this problem before... The only thing which I can recommend is to try to reinstall the "rJava" package.

Actually, there is another, more radical and time-consuming, but straightforward solution: to remove FishResp, R including all the R packages, and Java JDK with other Java components from your MacBook (see and, respectively). Then reinstall everything (latest versions, excluding JDK - it should be JDK 8u221) and try to run FishResp once more.

Current versions of software on my MacBook are:

  • R 3.6.1
  • rJava_0.9-11
  • JDK 8u221
  • FishResp GUI 1.0

Sorry for such challenges with installing GUI app.

Hi Melissa and other MacOS users,

I know, that it is not actual anymore for you, but I have met the same problem on my 'new' MacBook Pro.

I have figured out what was the issue: R version 3.X.X and Java JDK version 8 for some reasons did not communicate well. Since developers of Java SDK version >9 eliminated JavaFX (which is a graphical framework of FishResp), thus I asked you to use only Java SDK version 8.

However, yesterday, I found two independent open-source projects where JavaJDK 11 and JavaSDK 17 (the latest LTS version) included JavaFX for all operational systems: Liberica JDK or Zulu JDKNote, you should download a full version JDK (around 250 Mb), not a default 'Standard JDK' and install it to your MacOS. Then, download the recent the latest version of R (in my case it is 4.1.2), and launch the FishResp GUI app.

No issues have been observed with this installation pipeline.

Best wishes,